Sunday 26 June 2022

Network key point - my reference

                            Virtual Switch System configuration in Cisco 4500x

Both switches should be identical. We tried to create VSS between

  •  4500x 32 port and 4500x 16 port but it failed
  • 4500x running different version of IOS fails

Configuration on 4500x 

------------------------------

core1

-----
switch virtual domain 10
switch 1
switch 1 priority 200
exit

int po1
switchport
switch virtual link 1
no shutdown
switchport mode trunk 
exit

inter range tengigabitethernet 1/31-32
channel-group 1 mode on
exit

switch convert virtual
yes for reload


core2

-----
switch virtual domain 10
switch 2
exit

interface po2
switchport
switch virtual link 2
no shutdown
switchport mode trunk
exit

int range tenGigabitEthernet 1/31-32
channel-group 2 mode on
exit

switch convert mode virtual
yes for reload

-------------------


 

Network Key Points - My Reference

The main purpose of STP is to prevent switching loops in a network with redundant switched paths.

The purpose of the blocking state is to prevent the use of looped paths. A port in listening state prepares to forward data frames without populating the MAC address table. A port in learning state populates the MAC address table but doesn’t forward data frames. A port in forwarding state sends and receives all data frames on the bridged port. Also, a port in the disabled state is virtually nonoperational.

show spanning-tree,  root bridge of each VLAN. show spanning-tree summary command to help you get a quick glimpse of your STP network and root bridges.

PortFast allows a port to transition to the forwarding state immediately upon a connection. Because you don’t want other switches connecting to this port, BPDU Guard will shut down a PortFast port if it receives a BPDU.

(config-if) # spanning-tree portfast ,  # spanning-tree vlan 5 root primary # spanning-tree bpduguard enable (to avoid loops on portfast enabled ports, bpdugaurd blocks ports if  any non host port connect to the port with err-disable error. do shut and no shut) 

EtherChannel allows you to bundle links(2-8 ports) to get more bandwidth, instead of allowing STP to shut down redundant ports configure Cisco’s PAgP or the IEEE version, LACP, by creating a port channel interface and assigning the port channel group number to the interfaces you are bundling. show etherchannel port-channel

interface port-channel 1 >  interface range ge0/1-2 > channel-group 1 mode active > show ehterchannel port-channel > show etherchannnel summary

dir flash0

copy usbflash0:filename_ios.bin flash:
verify /md5 flash:/file_ios.bin
install win_md5sum to compare the md5 or simply copy it md5 copy file from cisco site along with ios and compare
"
config t
int range g1/0/1 - 24
no shutdown
spanning-tree portfast
config t
int vlan 1
no shutdown
ip address [ip address] [subnet mask]
exit
exit
wr mem
config t
ip route 0.0.0.0 0.0.0.0 [ip address of gateway]
exit

#configuration for telnet 

config t
line 0 4
password [password]
login
transport input all

exit

config t
enable password [password]
exit

#password for local console
config t
line con 0
password [password]
login
exit

#configuration for ssh
config t
hostname [hostname]
ip domain-name [domain name]
crypto key generate rsa
2048
ip ssh time-out 120
ip ssh version 2
exit


config t
username qcadmin password qcpass
exit
config t
aaa new-model
exit

#to enable oob
config t
int g0/0
ip address [ip address] 255.255.255.0
no shutdown
exit


No comments:

Post a Comment